2013年06月13日

jQuery2.0以上はIE8では動かない

普段、Chrome や Safari を使っていて Internet Explorer は使わなかったので知らなかったのですが、 jQuery2.0 以降では、 Internet Explorer 6, 7, 8 はサポートせずのようです。
You asked for it, you got it: jQuery 2.0 has arrived!

As promised, this version leaves behind the older Internet Explorer 6, 7, and 8 browsers.

仕事だったのでしょうがなく IE8 で動きを確認したところ、よりによって jquery.min.js でエラーになってしまい、 その原因を調べていて今更ながらこの情報を知るという。。。

それ以上に IE8 で「開発者ツール」というのができていて、Firebug 的なものができていたのに驚かされましたが。

IE8 などで jQuery が使いたい場合は、1.9.x などを使えば OK です。
ラベル:jquery javascript
posted by おちエン at 04:47| Comment(0) | 開発 | このブログの読者になる | 更新情報をチェックする

広告


この広告は60日以上更新がないブログに表示がされております。

以下のいずれかの方法で非表示にすることが可能です。

・記事の投稿、編集をおこなう
・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。


×

この広告は1年以上新しい記事の投稿がないブログに表示されております。